Skip to main content
Organisation and user technical requirements for the Entrust virtual smartcard

Understand the technical requirements and warranted environment specification for using Entrust virtual smartcards.

User requirements

Users must:

  • have an email address registered to an approved domain

See a list of email domains on the allow list for CIS

Allowed email addresses end in one of the following:

  • nhs.net
  • nhs.uk
  • gov.uk
  • advancedcomputersoftware.com
  • bfwml.co.uk
  • careuk.com
  • cjsm.net
  • coxrobinson.co.uk
  • enfield.gov.uk
  • hcahealthcare.co.uk
  • manorpharmacy.co.uk
  • mod.uk
  • murrays.co.uk
  • mymail.murrays.co.uk
  • police.uk
  • ramsayhealth.co.uk
  • servelec-healthcare.com
  • spirehealthcare.com
  • virgincare.co.uk
  • yourhealthcare.org
  • have a Bluetooth enabled mobile device, which will be available to them and in their sole control throughout authenticated sessions, running:
    • Android version 4.4 or above
    • iOS version 11 or above

Organisation requirements and warranted environment limitations

The end user machines (laptop or desktop computers) must:

  • use the following Windows builds
    • Windows 10 - builds 1803, 1903 or above (Note that there are compatibility issues with Windows 10 build 1809 and this build is not recommended by Entrust for use with their virtual smartcard)
    • Windows 8.1 or above
  • have NHS Digital Identity Agent v2.3 or above installed - Identity Agent v2.1.2.16 and above will work with the Entrust Virtual smartcard but it is only possible to determine which user’s virtual smartcard has been detected by the Identity Agent from v2.3
  • have Entrust virtual smartcard reader installed

We recommend using mobile devices and machines with Bluetooth version 4.0 and above for secure Bluetooth connections.

Last edited: 16 October 2020 2:23 pm